Remove S and SRC_URI from python daemon class

Initially this could be done in one place but as
sources move to git repositories this can't be done
in a generic manner.

Adapted existing recipes to this class change.
diff --git a/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass b/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
index 35c2714..9cb8bfd 100644
--- a/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
@@ -5,13 +5,11 @@
 inherit obmc-phosphor-license
 
 RDEPENDS_${PN} += "python-dbus python-pygobject"
-SRC_URI += " \
-        file://${PN}.py \
-        "
-S = "${WORKDIR}"
+INSTALL_NAME ?= "${PN}"
+SCRIPT_NAME ?= "${INSTALL_NAME}.py"
 
 do_install_append() {
         # install the script
         install -d ${D}${sbindir}
-        install -m 0755 ${WORKDIR}/${PN}.py ${D}${sbindir}/${PN}
+        install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME}
 }