Remove redundant code to set root password

Background: The OpenBmc project default root account password is set
in meta-phosphor/conf/distro/include/phosphor-defaults.inc and can be
customized in each layer's local.conf file.

Many of these local.conf.sample files had redundant code to set the
password, which probably should not have been there.  Removing them
allows the defaults in phosphor-defaults.inc to take effect.

Tested: No.  Only meta-ibm was tested.

Signed-off-by: Joseph Reynolds <joseph-reynolds@charter.net>
Change-Id: I76dce00d269d7afa005d7bcfd63f846d3cf45596
diff --git a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 57260f0..45061f7 100644
--- a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -33,6 +33,7 @@
 #     The service account does not have a home directory.  The home directory is
 #     set to / (the root directory) to allow dropbear ssh connections.
 
+# Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
 inherit extrausers
 
 # The password hash used here is the traditional 0penBmc password.