blob: f9322d4866b4cee13f1abcd62c3e26a0f84b5f61 [file] [log] [blame]
SUMMARY = "Keyboard configuration database for X Window"
DESCRIPTION = "The non-arch keyboard configuration database for X \
Window. The goal is to provide the consistent, well-structured, \
frequently released open source of X keyboard configuration data for X \
Window System implementations. The project is targeted to XKB-based \
systems."
HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
LICENSE = "MIT & MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "eb1383a5ac4b6210d7c7302b9d6fab052abdf51c5d2c9b55f1f779997ba68c6c"
SECTION = "x11/libs"
DEPENDS = "util-macros libxslt-native"
EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
FILES:${PN} += "${datadir}/X11/xkb"
inherit meson pkgconfig gettext python3native
do_install:append () {
install -d ${D}${datadir}/X11/xkb/compiled
cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
}
BBCLASSEXTEND += "native"