bytedance: Limit coredump size

Override coredump.conf and set the max size of coredump to 2MiB.

Tested: Verify systemd removes the old coredumps and makes sure the max
        size is around 2MiB.

Signed-off-by: Lei YU <yulei.sh@bytedance.com>
Change-Id: I9ae2ba46edd2b1e1b12537f12ca09f97882a7d40
diff --git a/meta-bytedance/recipes-core/systemd/systemd_%.bbappend b/meta-bytedance/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..2bdee49
--- /dev/null
+++ b/meta-bytedance/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,3 @@
+do_install_append () {
+    rm ${D}${sysconfdir}/systemd/coredump.conf
+}