fans:rainier: Install fan application config files

Install all the fan application config files into a rainier image

(From meta-ibm rev: dd3117e5c3b6768ca6975b04ebc70f8e716529b2)

Change-Id: I51d017b3a6ad34595bc9dce0fd1693c0012fc52e
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index 9442477..efbdea1 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -1,11 +1,31 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 
 SRC_URI_witherspoon = "file://config.json"
+SRC_URI_rainier = "file://rainier-2u/config.json \
+                   file://rainier-4u/config.json \
+                   file://everest/config.json \
+                   "
 
 do_install_witherspoon() {
         install -d ${D}/${datadir}/phosphor-fan-presence/presence/
         install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
 }
+do_install_rainier() {
+        # Install Rainier-2U/4U fan presence config files
+        install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
+        install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+        install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
+        install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+
+        # Install Everest fan presence config file
+        install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
+        install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
+}
 
 FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
 FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
+
+FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"