Add BMC accessible FRUs to generate FRU map

At present MRW does not have FRU ID's for BMC accessible
FRUs, so supporting by hand coding the config details.

Resolves openbmc/openbmc#1931

Change-Id: Ia33aa56378fe0e31df722b9134c041e66a5133d5
Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 45cb2ee..9a46307 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -21,7 +21,7 @@
 DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "obmc-targets"
 DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
-DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
+DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
 
 RDEPENDS_${PN}-dev += "phosphor-logging"
 RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
@@ -47,7 +47,7 @@
         WHITELIST_CONF="${WHITELIST_CONF}" \
         SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
         INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
-        FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
+        FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
         "
 
 S = "${WORKDIR}/git"