phosphor-state-manager: fix bmc ready boot config

Noticed the following warning recently:

```
do_configure: QA Issue: phosphor-state-manager: invalid PACKAGECONFIG: only-allow-boot-when-bmc-ready [invalid-packageconfig]
```

This is because the PACKAGECONFIG used by the bbappend to enable this
new feature did not match with what was in the recipe. Update the base
recipe to define it as was meant initially.

Tested:
- Confirmed no more warning

Change-Id: I4b76ec761a44013467a2129a992df6d69ea8f1e7
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 897a7ce..048a71a 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -37,7 +37,7 @@
 
 PACKAGECONFIG ??= "no-warm-reboot \
                    only-run-apr-on-power-loss \
-                   only-boot-when-bmc-ready"
+                   only-allow-boot-when-bmc-ready"
 
 # Disable warm reboots of host
 PACKAGECONFIG[no-warm-reboot] = "-Dwarm-reboot=disabled,-Dwarm-reboot=enabled"
@@ -46,7 +46,7 @@
 PACKAGECONFIG[only-run-apr-on-power-loss] = "-Donly-run-apr-on-power-loss=true,-Donly-run-apr-on-power-loss=false"
 
 # Only allow boot operations when BMC is in Ready state
-PACKAGECONFIG[only-boot-when-bmc-ready] = "-Donly-allow-boot-when-bmc-ready=true,-Donly-allow-boot-when-bmc-ready=false"
+PACKAGECONFIG[only-allow-boot-when-bmc-ready] = "-Donly-allow-boot-when-bmc-ready=true,-Donly-allow-boot-when-bmc-ready=false"
 
 # The host-check function will check if the host is running
 # after a BMC reset.