phosphor-host-postd: Use meson

Now that meson support is ready, build using meson
instead of autotools

(From meta-phosphor rev: 69c2c41ddc9ff7f44a34f9bb4b9225a75729ab96)

Signed-off-by: Kun Yi <kunyi731@gmail.com>
Change-Id: I76a4d531fd25dd29ec6164b68f7c2c07f187bed8
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
index e400893..e263cdb 100644
--- a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -6,13 +6,13 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit autotools pkgconfig
+inherit meson
+inherit pkgconfig
 inherit systemd
 
 PACKAGECONFIG ?= ""
-PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev"
+PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
 
-DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-dbus-interfaces"
@@ -29,11 +29,9 @@
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
 
-EXTRA_OECONF = " \
-  SNOOP_DEVICE="${SNOOP_DEVICE}" \
-  POST_CODE_BYTES="${POST_CODE_BYTES}" \
-  SYSTEMD_TARGET="multi-user.target" \
-"
+EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
+EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
+EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
 
 POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
 SERVICE_FILE_7SEG = " \