stop-instructions should not cause host-stop fail

There have been some situations where things get so messed up that you
can not even stop the instructions on your processor. When this happens,
the systemd target, obmc-host-stop can not complete. This really should
be a wants relationship vs. a requires so that the target can continue
to stop the host even when this service fails.

(From meta-openpower rev: 8dfb06a8656eeff1c0393607a5bf9cdc6320aae5)

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I2704fecab789d6ffa8e274c37d0653bf64f3c8b0
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index b8105fc..8185ddf 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -12,10 +12,10 @@
 ALLOW_EMPTY_${PN} = "1"
 
 pkg_postinst_${PN}() {
-	mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+	mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
 	mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
 
-	LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+	LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
 	TARGET="../op-stop-instructions@.service"
 	ln -s $TARGET $LINK
 
@@ -33,7 +33,7 @@
 }
 
 pkg_prerm_${PN}() {
-	LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+	LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
 	rm $LINK
 	LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
 	rm $LINK