meta-ibm: dbus: ibm-dbus-interfaces: rename as git

Rename ibm-dbus-interfaces.bb to _git.bb per OE norms.

(From meta-ibm rev: 36f78498cb4dc2e3bbba3ad32f4e00baaa6d7e8d)

Change-Id: If99664a7d6409d3845719f1528a0a1aba45b06af
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
new file mode 100644
index 0000000..3744703
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "IBM DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
+SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libibm_dbus"
+PACKAGECONFIG[libibm_dbus] = " \
+        --enable-libibm_dbus, \
+        --disable-libibm_dbus, \
+        systemd sdbusplus, \
+        libsystemd sdbusplus \
+        "
+
+PACKAGECONFIG_remove_class-native = "libibm_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
+
+BBCLASSEXTEND += "native nativesdk"