treewide: remove pointless abstractions

All of these abstractions have exactly one implementation.  Remove the
indirection to improve at a glance comprehension.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I5d701aff6d0876fa3b2d16c841cbdcb0433b221f
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
index 8f99b24..3e5f87a 100644
--- a/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
@@ -5,7 +5,7 @@
 
 inherit obmc-phosphor-systemd
 
-RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "phosphor-gpio-monitor-monitor"
 RDEPENDS:${PN} += "busybox"
 
 RESET_SERVICE = "reset-fan-watchdog.service"