phosphor-skeleton-control-power: install service properly

The latest systemd requires templated services be installed properly. As
this is skeleton, just do the minimum to get the service installed
properly.

Tested:
- Confirmed service installed as expected:
```
/rootfs/usr/lib/systemd/system/multi-user.target.wants/org.openbmc.control.Power@0.service
```

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I36607d361ba8b6a9c8055435e8af5dba12dd07eb
diff --git a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
index 5802bd3..aae0480 100644
--- a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
@@ -11,8 +11,11 @@
 
 SKELETON_DIR = "op-pwrctl"
 
-OBMC_CONTROL_POWER_FMT ?= "org.openbmc.control.Power@{0}.service"
-DBUS_SERVICE:${PN} += "${@compose_list(d, 'OBMC_CONTROL_POWER_FMT', 'OBMC_POWER_INSTANCES')}"
+DBUS_SERVICE:${PN} += "org.openbmc.control.Power@.service"
+OBMC_CONTROL_INST = "org.openbmc.control.Power@{0}.service"
+OBMC_CONTROL_SVC = "org.openbmc.control.Power@.service"
+OBMC_CONTROL_FMT = "../${OBMC_CONTROL_SVC}:multi-user.target.wants/${OBMC_CONTROL_INST}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'OBMC_CONTROL_FMT', 'OBMC_POWER_INSTANCES')}"
 
 SYSTEMD_SERVICE:${PN} += " \
         phosphor-wait-power-on@.service \