meta-phosphor: use systemd_system_unitdir

This variable was added to bitbake.conf so lets use it.  Using it is
best pratice and enables things like alternative base_libdir paths.

Change-Id: I181d12e02ca7918614dacec68bd8e033932eb0ab
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index ce5d799..e9577eb 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -8,7 +8,7 @@
 
 inherit systemd
 
-FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
+FILES_${PN} += "${systemd_system_unitdir}/rngd.service.d"
 
 do_install_append() {
 
@@ -18,9 +18,9 @@
     # go slower.
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         if ${@bb.utils.contains('PACKAGECONFIG', 'libjitterentropy', 'true', 'false', d)}; then
-            install -d ${D}${systemd_unitdir}/system/rngd.service.d
+            install -d ${D}${systemd_system_unitdir}/rngd.service.d
             install -m 644 ${WORKDIR}/10-nice.conf \
-                ${D}${systemd_unitdir}/system/rngd.service.d
+                ${D}${systemd_system_unitdir}/rngd.service.d
         fi
     fi
 }