subtree updates

meta-raspberrypi: cfbb192e5c..83f5577d8d:
  AJ Bagwell (1):
        linux-raspberrypi: add UBOOT_ENTRYPOINT to match LOADADDR

poky: ed98f1a1ae..30b38d9cb9:
  Alexander Kanavin (1):
        connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific

  Chen Qi (1):
        spirv-tools: fix to use sdk-1.3.204 branch

  Kevin Hao (1):
        kernel.bbclass: Fix the do_strip() malfunction

  Khem Raj (2):
        libarchive: Upgrade to 3.6.1
        musl: Move to 1.2.3 release tag

  Martin Jansa (1):
        license_image.bbclass: close package.manifest file

  Ralph Siemsen (2):
        xz: fix CVE-2022-1271
        gzip: upgrade 1.11 -> 1.12

  Richard Purdie (2):
        uninative: Upgrade to 3.6 with gcc 12 support
        package_ipk/deb: Fix specific version handling

  Ross Burton (1):
        python3-cryptography: backport fix for leaky test

meta-openembedded: b9e440ead8..1888971b1f:
  Andreas Müller (5):
        octave: add PACKAGECONFIG for (Qt-)gui - disabled by default
        xfce4-eyes-plugin: upgrade 4.5.1 -> 4.6.0
        gnome-online-accounts: upgrade 3.43.1 -> 3.44.0
        mutter: upgrade 41.2 -> 42.0
        gnome-shell: upgrade 41.2 -> 42.0

  Clément Péron (1):
        grpc: remove unused patches

  Kai Kang (2):
        wxwidgets: fix wx-config multilib issue
        python3-wxgtk4: pass '--baselib' to WX_CONFIG

  Khem Raj (6):
        Revert "python3-cppy: upgrade 1.2.0 -> 1.2.1"
        libotr: Include missing sys/socket.h header
        libcereal: Link in libatomic on rv32 for ptests
        gnuplot: Disable libcerf and fix typo
        libcereal: Disable on ppc/ppc64
        evolution-data-server: Disable g-i on musl

  Markus Volk (1):
        gparted: update to v1.4.0

  Naveen Saini (1):
        ndctl: fix build failure with EXEWRAPPER_ENABLED False

  Oleksandr Kravchuk (27):
        python3-beautifulsoup: update to 4.11.1
        python3-bidict: update to 0.22.0
        python3-can: update t 4.0.0
        python3-elementpath: update to 2.5.0
        python3-flask-login: update to 0.6.0
        python3-flask: update to 2.1.1
        python3-gcovr: update to 5.1
        python3-google-api-core: update to 2.7.1
        python3-google-auth: update to 2.6.3
        python3-grpcio-tools: update to 1.45.0
        python3-ipython: update to 8.2.0
        python3-jmespath: update to 1.0.0
        python3-mypy: update to 0.942
        python3-pint: update to 0.19.1
        python3-portalocker: update to 2.4.0
        python3-pulsectl: update to 22.3.2
        python3-pycurl: update to 7.45.1
        python3-pymogo: update to 4.1.0
        python3-pyscaffold: update to 4.2.1
        python3-pytest-helpers-namespace: update to 2021.12.29
        python3-pywbem: update to 1.4.1
        python3-regex: update to 2022.3.15
        python3-sympy: update to 1.10.1
        python3-tqdm: update to 4.64.1
        python3-twitter: update to 4.8.0
        python3-xmlschema: update to 1.10.0
        python3-zeroconf: update to 0.38.4

  Robert Yang (1):
        python3-wxgtk4: Require DISTRO_FEATURES as gtk3

  Sakib Sajal (1):
        drbd-utils: update 9.13.1 -> 9.20.2

  Scott Murray (1):
        wxwidgets: Fix building without x11

  Stefan Herbrechtsmeier (2):
        grpc: add cmake support for target
        grpc: remove useless link with libatomic append

  Stefan Schmidt (4):
        ot-br-posix: add recipe for an OpenThread Border Router
        ot-daemon: add recipe for OpenThread daemon
        wpantund: add new recipe
        MAINTAINERS: add entry for OpenThread

  Willy Tu (1):
        googletests: Update SRC_URI to 9e71237 to move closer to lastest version

  Yi Zhao (1):
        libyang: do not inherit binconfig-disabled

  wangmy (9):
        haveged: upgrade 1.9.17 -> 1.9.18
        hidapi: upgrade 0.10.1 -> 0.11.2
        hwdata: upgrade 0.357 -> 0.358
        broadcom-bt-firmware: upgrade 12.0.1.1105_p2 -> 12.0.1.1105_p3
        byacc: upgrade 20211224 -> 20220128
        ctags: upgrade 5.9.20211114.0 -> 5.9.20220410.0
        feh: upgrade 3.6.1 -> 3.8
        fio: upgrade 3.29 -> 3.30
        grpc: upgrade 1.45.1 -> 1.45.2

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ia6d6cf07c9398a7885df6b31b27019da4d8f01d8
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb b/meta-openembedded/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
new file mode 100644
index 0000000..f54d966
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
@@ -0,0 +1,71 @@
+SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+DEPENDS = " \
+    libxml2-native \
+    sassc-native \
+    gtk4 \
+    mutter \
+    evolution-data-server \
+    gcr \
+    gjs \
+    gnome-autoar \
+    polkit \
+    libcroco \
+    startup-notification \
+    ibus \
+    gsettings-desktop-schemas \
+"
+
+inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
+
+REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
+
+GTKIC_VERSION = "4"
+GTKDOC_MESON_OPTION = "gtk_doc"
+GIR_MESON_OPTION = ""
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
+
+SRC_URI[archive.sha256sum] = "33d404fb3c93b9de42984f0110a2969d6a4a7247c27fe7f5e24c67ecfec75094"
+SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
+
+PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
+PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
+PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
+
+EXTRA_OEMESON = " \
+    -Dgjs_path=${bindir}/gjs \
+    -Dextensions-app:gjs_path=${bindir}/gjs \
+    -Dtests=false \
+    -Dman=false \
+"
+
+do_install:append() {
+    # fix shebangs
+    for tool in `find ${D}${bindir} -name '*-tool'`; do
+        sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
+    done
+}
+
+GSETTINGS_PACKAGE = "${PN}-gsettings"
+
+FILES:${PN} += " \
+    ${datadir}/metainfo \
+    ${datadir}/dbus-1 \
+    ${datadir}/gnome-control-center \
+    ${datadir}/xdg-desktop-portal \
+    ${systemd_user_unitdir} \
+"
+
+RDEPENDS:${PN} += "gnome-desktop gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings"
+
+PACKAGES =+ "${PN}-tools ${PN}-gsettings"
+FILES:${PN}-tools = "${bindir}/*-tool"
+RDEPENDS:${PN}-tools = "python3-core"
+