subtree updates
meta-raspberrypi: cfbb192e5c..83f5577d8d:
AJ Bagwell (1):
linux-raspberrypi: add UBOOT_ENTRYPOINT to match LOADADDR
poky: ed98f1a1ae..30b38d9cb9:
Alexander Kanavin (1):
connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific
Chen Qi (1):
spirv-tools: fix to use sdk-1.3.204 branch
Kevin Hao (1):
kernel.bbclass: Fix the do_strip() malfunction
Khem Raj (2):
libarchive: Upgrade to 3.6.1
musl: Move to 1.2.3 release tag
Martin Jansa (1):
license_image.bbclass: close package.manifest file
Ralph Siemsen (2):
xz: fix CVE-2022-1271
gzip: upgrade 1.11 -> 1.12
Richard Purdie (2):
uninative: Upgrade to 3.6 with gcc 12 support
package_ipk/deb: Fix specific version handling
Ross Burton (1):
python3-cryptography: backport fix for leaky test
meta-openembedded: b9e440ead8..1888971b1f:
Andreas Müller (5):
octave: add PACKAGECONFIG for (Qt-)gui - disabled by default
xfce4-eyes-plugin: upgrade 4.5.1 -> 4.6.0
gnome-online-accounts: upgrade 3.43.1 -> 3.44.0
mutter: upgrade 41.2 -> 42.0
gnome-shell: upgrade 41.2 -> 42.0
Clément Péron (1):
grpc: remove unused patches
Kai Kang (2):
wxwidgets: fix wx-config multilib issue
python3-wxgtk4: pass '--baselib' to WX_CONFIG
Khem Raj (6):
Revert "python3-cppy: upgrade 1.2.0 -> 1.2.1"
libotr: Include missing sys/socket.h header
libcereal: Link in libatomic on rv32 for ptests
gnuplot: Disable libcerf and fix typo
libcereal: Disable on ppc/ppc64
evolution-data-server: Disable g-i on musl
Markus Volk (1):
gparted: update to v1.4.0
Naveen Saini (1):
ndctl: fix build failure with EXEWRAPPER_ENABLED False
Oleksandr Kravchuk (27):
python3-beautifulsoup: update to 4.11.1
python3-bidict: update to 0.22.0
python3-can: update t 4.0.0
python3-elementpath: update to 2.5.0
python3-flask-login: update to 0.6.0
python3-flask: update to 2.1.1
python3-gcovr: update to 5.1
python3-google-api-core: update to 2.7.1
python3-google-auth: update to 2.6.3
python3-grpcio-tools: update to 1.45.0
python3-ipython: update to 8.2.0
python3-jmespath: update to 1.0.0
python3-mypy: update to 0.942
python3-pint: update to 0.19.1
python3-portalocker: update to 2.4.0
python3-pulsectl: update to 22.3.2
python3-pycurl: update to 7.45.1
python3-pymogo: update to 4.1.0
python3-pyscaffold: update to 4.2.1
python3-pytest-helpers-namespace: update to 2021.12.29
python3-pywbem: update to 1.4.1
python3-regex: update to 2022.3.15
python3-sympy: update to 1.10.1
python3-tqdm: update to 4.64.1
python3-twitter: update to 4.8.0
python3-xmlschema: update to 1.10.0
python3-zeroconf: update to 0.38.4
Robert Yang (1):
python3-wxgtk4: Require DISTRO_FEATURES as gtk3
Sakib Sajal (1):
drbd-utils: update 9.13.1 -> 9.20.2
Scott Murray (1):
wxwidgets: Fix building without x11
Stefan Herbrechtsmeier (2):
grpc: add cmake support for target
grpc: remove useless link with libatomic append
Stefan Schmidt (4):
ot-br-posix: add recipe for an OpenThread Border Router
ot-daemon: add recipe for OpenThread daemon
wpantund: add new recipe
MAINTAINERS: add entry for OpenThread
Willy Tu (1):
googletests: Update SRC_URI to 9e71237 to move closer to lastest version
Yi Zhao (1):
libyang: do not inherit binconfig-disabled
wangmy (9):
haveged: upgrade 1.9.17 -> 1.9.18
hidapi: upgrade 0.10.1 -> 0.11.2
hwdata: upgrade 0.357 -> 0.358
broadcom-bt-firmware: upgrade 12.0.1.1105_p2 -> 12.0.1.1105_p3
byacc: upgrade 20211224 -> 20220128
ctags: upgrade 5.9.20211114.0 -> 5.9.20220410.0
feh: upgrade 3.6.1 -> 3.8
fio: upgrade 3.29 -> 3.30
grpc: upgrade 1.45.1 -> 1.45.2
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ia6d6cf07c9398a7885df6b31b27019da4d8f01d8
diff --git a/poky/meta/recipes-extended/libarchive/libarchive_3.6.1.bb b/poky/meta/recipes-extended/libarchive/libarchive_3.6.1.bb
new file mode 100644
index 0000000..c795b41
--- /dev/null
+++ b/poky/meta/recipes-extended/libarchive/libarchive_3.6.1.bb
@@ -0,0 +1,67 @@
+SUMMARY = "Support for reading various archive formats"
+DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
+HOMEPAGE = "http://www.libarchive.org/"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
+
+DEPENDS = "e2fsprogs-native"
+
+PACKAGECONFIG ?= "zlib bz2 xz lzo zstd"
+
+PACKAGECONFIG:append:class-target = "\
+ ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
+"
+
+DEPENDS_BZIP2 = "bzip2-replacement-native"
+DEPENDS_BZIP2:class-target = "bzip2"
+
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
+PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
+PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
+PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
+PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
+PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
+PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
+PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
+PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
+PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd,"
+
+EXTRA_OECONF += "--enable-largefile"
+
+SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz"
+UPSTREAM_CHECK_URI = "http://libarchive.org/"
+
+SRC_URI[sha256sum] = "c676146577d989189940f1959d9e3980d28513d74eedfbc6b7f15ea45fe54ee2"
+
+inherit autotools update-alternatives pkgconfig
+
+CPPFLAGS += "-I${WORKDIR}/extra-includes"
+
+do_configure[cleandirs] += "${WORKDIR}/extra-includes"
+do_configure:prepend() {
+ # We just need the headers for some type constants, so no need to
+ # build all of e2fsprogs for the target
+ cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
+}
+
+ALTERNATIVE_PRIORITY = "80"
+
+PACKAGES =+ "bsdtar"
+FILES:bsdtar = "${bindir}/bsdtar"
+
+ALTERNATIVE:bsdtar = "tar"
+ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
+ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
+
+PACKAGES =+ "bsdcpio"
+FILES:bsdcpio = "${bindir}/bsdcpio"
+
+ALTERNATIVE:bsdcpio = "cpio"
+ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
+ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
+
+BBCLASSEXTEND = "native nativesdk"