blob: e64f196004650a53c398661e7c42c557e68922c0 [file] [log] [blame]
SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
AUTHOR = "Anthon van der Neut"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa0a51dfb461e2f803969e0f3fa71dfe"
PYPI_PACKAGE = "ruamel.yaml"
inherit pypi setuptools3
SRC_URI[sha256sum] = "1a771fc92d3823682b7f0893ad56cb5a5c87c48e62b5399d6f42c8759a583b33"
RDEPENDS:${PN} += "\
${PYTHON_PN}-shell \
${PYTHON_PN}-datetime \
${PYTHON_PN}-netclient \
"
do_install:prepend() {
export RUAMEL_NO_PIP_INSTALL_CHECK=1
}
BBCLASSEXTEND = "native nativesdk"