Partially revert "treewide: remove obmc-system-mgmt feature"

The obmc-system-mgmt feature is currently used in the image to trigger
inclusion of a virtual-provider which provides a number of packages many
systems need.  Partially revert the removal of this feature so that
the outcome is:

    1. The empty obmc-phosphor-sysd package is still removed.
    2. By default the 'obmc-system-mgmt' feature is included, unless
       specifically exempted.
    3. All EVB platforms remove the 'obmc-system-mgmt' feature since
       they have no system they are managing.

This partially reverts commit 060ad3ff7fcc30aff78a9e504efee9d8fa0d4526.

Tested:

  * Built `bletchley` and confirmed `packagegroup-fb-apps-system` and
    `entity-manager` are present.

```
entity-manager armv7ahf-vfpv4d16 0.1+git0+6bf41588ab-r0
packagegroup-fb-apps-system all 1.0-r1
```
  * Built `witherspoon` and confirmed `packagegroup-op-apps-system` and
    `pdbg` are present.

```
packagegroup-op-apps-system noarch 1.0
pdbg arm1176jzs 3.3
```

  * Ran `bitbake -p` on `evb-ast2600` to confirm the undefined
    `virtual-obmc-system-mgmt` is not being included in the image.

Change-Id: I8b7804d5101cc84a2c57473b3f85672bf7767c67
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 572ec80..80c16d2 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -27,6 +27,7 @@
 # - obmc-sensors                      - OpenBMC sensor support
 # - obmc-settings-mgmt                - OpenBMC settings management
 # - obmc-software                     - OpenBMC software management
+# - obmc-system-mgmt                  - OpenBMC system management
 # - obmc-telemetry                    - OpenBMC telemetry solution
 # - obmc-user-mgmt                    - OpenBMC user management
 # - obmc-user-mgmt-ldap               - OpenBMC LDAP users
@@ -58,6 +59,7 @@
 FEATURE_PACKAGES_obmc-net-ipmi ?= "phosphor-ipmi-net"
 FEATURE_PACKAGES_obmc-sensors ?= "packagegroup-obmc-apps-sensors"
 FEATURE_PACKAGES_obmc-software ?= "packagegroup-obmc-apps-software"
+FEATURE_PACKAGES_obmc-system-mgmt ?= "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-phosphor-system-mgmt', 'virtual-obmc-system-mgmt', '', d)}"
 FEATURE_PACKAGES_obmc-debug-collector ?= "packagegroup-obmc-apps-debug-collector"
 FEATURE_PACKAGES_obmc-settings-mgmt ?= "packagegroup-obmc-apps-settings"
 FEATURE_PACKAGES_obmc-network-mgmt ?= "packagegroup-obmc-apps-network"