mboxd: Add systemd dependency

Fixes a bitbake race that causes mboxd to fail configure:

	checking pkg-config is at least version
	checking for LIBSYSTEMD...  no
	configure: error: libsytemd not found

Change-Id: I6d8f10546bfc0989d0e98ff49efef5ddbdc536ea
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
index 2d52a26..a5e1078 100644
--- a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
+++ b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
@@ -8,6 +8,7 @@
 inherit obmc-phosphor-systemd
 
 DEPENDS += "autoconf-archive-native"
+DEPENDS += "systemd"
 RDEPENDS_${PN} += "libsystemd"
 
 S = "${WORKDIR}/git"