meta-phosphor: add allowlist ipmid PACKAGECONFIG

Add a PACKAGECONFIG for the allowlist feature, so it can be disabled
without using EXTRA_OECONF and comply with the OpenBMC meta layer
guidelines.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I263dc9e8f9f65cc184482b149bcabe01b765326a
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 819435f..7ad4016 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -21,10 +21,11 @@
     whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
     return ' '.join(whitelists)
 
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "allowlist"
 PACKAGECONFIG[dynamic-sensors] = "--enable-dynamic-sensors,--disable-dynamic-sensors"
 PACKAGECONFIG[hybrid-sensors] = "--enable-hybrid-sensors,--disable-hybrid-sensors"
 PACKAGECONFIG[sel-logger-clears-sel] = "--enable-sel-logger-clears-sel,--disable-sel-logger-clears-sel"
+PACKAGECONFIG[allowlist] = "--enable-ipmi-whitelist,--disable-ipmi-whitelist"
 
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "nlohmann-json"