Fix up recipes to address missing fan apps

Change to use the "softer" default value for PACKAGECONFIG by default.
Change to append extra paths in bbappend for Witherspoon.
Fix up/change some names in bbappend file for Witherspoon.

Resolves openbmc/openbmc#1765

Change-Id: I316e1e857b008ccd67e922698ee7e0a9c5d222fc
Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
index e7f8dc7..7e002b7 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
@@ -27,7 +27,7 @@
 
 PACKAGES_remove = "${PN}"
 PACKAGES += "${FAN_PACKAGES}"
-PACKAGECONFIG ??= "presence control monitor"
+PACKAGECONFIG ?= "presence control monitor"
 SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
 RDEPENDS_${PN}-dev = "${FAN_PACKAGES}"
 RDEPENDS_${PN}-staticdev = "${FAN_PACKAGES}"