meta-phosphor: make discovery bbclass use override syntax

In the spirit of consistency with the new upstream override
syntax, change phosphor-discovery-service.bbclass to use it
and make tree-wide changes as appropriate.

After the change checked on Witherspoon on QEMU:
```
root@witherspoon:/etc/avahi/services# ls
obmc_console.service  obmc_redfish.service  obmc_rest.service
```

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ib1fe3cce57a0130378af789abd83b457e0c3a318
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index 9360e21..2ca97e1 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -30,7 +30,7 @@
 SRC_URI:append:p10bmc = " file://client.2201.conf"
 SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf"
 
-REGISTERED_SERVICES_${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_guests:tcp:2201:"
 
 SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \
 		obmc-console-ssh@2201.service \
@@ -48,7 +48,7 @@
 SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf"
 SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf"
 
-REGISTERED_SERVICES_${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
+REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_guests:tcp:2201:"
 
 SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \
 		obmc-console-ssh@2201.service \