ipmi-fru: Move common config to include

Prepare for multiple recipes from a single repository.

Change-Id: Ia2604701a56095ba4750e857f484cf4dc4b26097
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
index d36a608..973f4eb 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -1,12 +1,13 @@
 SUMMARY = "Phosphor IPMI Inventory Plugin"
 DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
-HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
 PR = "r1"
 
 inherit autotools pkgconfig
 inherit obmc-phosphor-license
 inherit obmc-phosphor-systemd
 
+require ${PN}.inc
+
 DEPENDS += " \
         systemd \
         phosphor-ipmi-host \
@@ -18,9 +19,6 @@
 
 SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
 
-SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
-SRCREV = "ce3490e71f9f91bd20dbb9ac037079de4a3580a8"
-
 S = "${WORKDIR}/git"
 
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"