meta-quanta: gbs: back to upstream and enable chassis-system reset

- change back to x86-power-control upstream
- enable chassis-system reset for hard power cycle
  by Redfish

Usage by Redfish:
curl -k -u ${username}:${password}
  https://${bmcip}/redfish/v1/Chassis/chassis/Actions/Chassis.Reset
   -d '{"ResetType": "PowerCycle"}'

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Icff87d590c911289cb15bdc34dafce69e55c9e2a
diff --git a/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
index 804fcb0..33cc6d4 100644
--- a/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,4 +1,14 @@
-SRC_URI_gbs = "git://github.com/quanta-bmc/x86-power-control.git"
-SRCREV_gbs = "70389494989e438af6b8b1d3b4db602a68f2f9da"
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://power-config-host0.json \
+                       file://chassis-system-reset.service \
+                     "
 
-SYSTEMD_SERVICE_${PN}_gbs = "xyz.openbmc_project.Chassis.Control.Power.service"
+EXTRA_OECMAKE_append_gbs = " -DCHASSIS_SYSTEM_RESET=ON"
+
+RDEPENDS_${PN}_append_gbs = " bash"
+RDEPENDS_${PN}_append_gbs = " gbs-hotswap-power-cycle"
+
+do_install_append_gbs() {
+    install -d ${D}${datadir}/${PN}
+    install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${PN}
+}