meta-raspberrypi: subtree update:0e9c32c816..6f85611576

Alex Gonzalez (1):
      linux-raspberrypi: Only deploy cmdline.txt for the main kernel

Khem Raj (7):
      linux-firmware-rpidistro: Update to 20190114-1+rpt8
      linux-raspberrypi_5.4.bb: Update to 5.4.69
      raspberrypi-firmware: Update to 20201002 snapshot
      raspberrypi-tools: Update to latest snapshot as of 20200803
      oeqa: Add 5.4 specific error messages to ignore list
      rpi-default-settings: Replace default parselogs with parselogs_rpi
      layer.conf: Add gatesgarth to LAYERSERIES_COMPAT

Madhavan Krishnan (1):
      libcamera: Define packageconfig to enable rpi pipeline

Martin Jansa (2):
      linux-raspberrypi-5.4: bump SRCREV to fix raspberrypi3-64 builds
      python3-rtimu: don't use trailing slash in S

Murat Kilivan (1):
      linux-raspberrypi_5.4.bb: Add kernel-cache source

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I906081b851f3733a52c1899fe2b4e835021f6419
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 833f8f6..99afde8 100644
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -35,8 +35,8 @@
 
 SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree"
 
-SRCREV = "616fc2dd4df421e3974179d9e46d45e7006aeb28"
-PV = "20190114-1+rpt6"
+SRCREV = "98e815735e2c805d65994ccc608f399595b74438"
+PV = "20190114-1+rpt8"
 
 S = "${WORKDIR}/git"
 
@@ -59,6 +59,11 @@
     for fw in brcmfmac43430-sdio brcmfmac43455-sdio ; do
         install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
     done
+    # add compat links. Fixes errors like
+    # brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
+    ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+    ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+    ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
 }
 
 PACKAGES = "\