meta-ibm: update DEPENDS for sdbusplus-native

sdbusplus has changed the package layout so that sdbusplus-native and
sdbus++-native are now ${PYTHON_PN}-sdbus++-native.  Update recipes
that need to use sdbus++ (or its associated python modules) or remove
the DEPENDS if it is no longer necessary.

(From meta-ibm rev: 0b7c2ef33825f9672c60481ce5d84b240a1f38c3)

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I80e4b2f244f3ec9b2576e623f2f78ff6ccf406d1
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
index d22b471..99b933a 100644
--- a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
+++ b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces_git.bb
@@ -8,24 +8,21 @@
 S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
 inherit phosphor-dbus-yaml
 
 DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
 
 SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
 SRCREV = "109271bb4de159b9cf13c56acded3eb79bff61fb"
 
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
 PACKAGECONFIG ??= "libibm_dbus"
 PACKAGECONFIG[libibm_dbus] = " \
         --enable-libibm_dbus, \
         --disable-libibm_dbus, \
         systemd sdbusplus, \
-        libsystemd sdbusplus \
+        libsystemd \
         "
 
 PACKAGECONFIG_remove_class-native = "libibm_dbus"