meta-nuvoton: npcm8xx-tip-fw: update to 0.5.3.0.4.2

Changelog:

TIP_FW_L0_0.5.3_L1_0.4.2
==============
- TIP_FW L0 version 0.5.3 and L1 version 0.4.2 L1
- FreeRTOS: in case of assert: print useful info.
- NVIC_BMC_reset: clear NVIC int before reloading BMC.
- in BMC reset and spurious interrupt reset: read the int number from
  the active and not the pending.
- NVIC_IntHandlerCommon: bug fix: clear correct number.
- Big fix: enable all traps in hardware_app_init.
- Add task bmc_task to handle BMC reset reload.
- Increase heap_size to 0xA000.
- HOSTPER: set to 1 till KCS bug is fixed.
- Flash: check if FIU1 and FIU 0\CS1 are disabled by OTP bit.
- Flash: bug fix: do not enable FIU1 CS2\3.
- Flash: Allow using a 4MB flash for image.
- Update FreeRTOS to none-MPU version.
- Spurious interrupt handling: in case of spurious interrupt print
  correct int number + NVIC state, and then clear it.
- OTP version: use two bits for each version number.
- Copy DBGRST too to INTCR2.
- Debug log: bug fix: data corruption in case of a 16MB flash. Replace
  the code so that Debug log is 64KB (one flash block). its location is
  - split flash for active recovery:  64KB before recovery image.
  - two flash mode: last block in active flash.
- UUID: add full data read (wafer, X\Y, year, work week). Note: debug
  chips do not contain this info.

TIP FW 0.5.1 L0 0.4.0 L1
==============
- Set RCR regs only in PORST.
- Change RCR values for TIP reset.
- NVIC: print more data on spurious interrupts.
- SPIX - set FIU_FIX to SINGLES. Other FIUs remain in INCREASING mode as
  before.

TIP FW 0.5.1 L0 0.4.0 L1 GOOGLE4
==============
- derived from TIP FW 0.5.1 L0 0.4.0 L1

Tested:
buid pass and boot up successful with correct TIP FW latest version.

Signed-off-by: Tim Lee <timlee660101@gmail.com>
Change-Id: I2b5093470d6caa2e26bb287ec7dda3a8d0c4404c
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb
new file mode 100644
index 0000000..8494c4c
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb
@@ -0,0 +1,11 @@
+SRCREV = "e9bc9838f49402c185bf987dab362e5a938cdd5a"
+
+OUTPUT_BIN = "output_binaries_${DEVICE_GEN}_${IGPS_MACHINE}"
+
+SRC_URI[output_binaries_A1_EB.sha256sum] = "5ea2f796ee2a917700f9a8d0e2bc7a2fa6c540573df81956cb9a73aba3bfd2e0"
+SRC_URI[output_binaries_A1_Google.sha256sum] = "c07d740093b0599e76463456c5b0a2325a9da9fa99cae2f7a349a68f837e60d1"
+SRC_URI[output_binaries_A1_SVB.sha256sum] = "57af59c6e2cfb7cc91865aa9fc434ac57fa39ecee51cb63c07d0ba56bc21526f"
+SRC_URI[output_binaries_Z1_EB.sha256sum] = "9ab9e17f7502fbe5d7a17a4e4f29614f369c799ba2896e8428b31bd4a2a765e0"
+SRC_URI[output_binaries_Z1_SVB.sha256sum] = "3c23d41421706f0f14db239b474811bdff9d39564c6a618304ab56bcd706550c"
+
+require npcm8xx-tip-fw.inc