meta-raspberrypi: subtree update:0d398a3b71..e2c1992955

Christopher Clark (1):
      rpi-base: add SERIAL_CONSOLES_CHECK to default to SERIAL_CONSOLES

Khem Raj (1):
      userland: Update to 2020-06-24 top commit

Pierre-Jean Texier (2):
      linux-raspberrypi: bump to Linux version 5.4.51
      raspberrypi-firmware: update to current HEAD

colin (3):
      conf/machine/include/rpi-base.inc: Added can1 interface to bsp
      rpi-config_git: Added ENABLE_DUAL_CAN build configuration
      docs: Added documentation for Pican2 Duo support

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I5e0c26ab7cabb4c931cbfef190b5b4b3ce257fdf
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index d964de5..afdbce6 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -198,8 +198,13 @@
         echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
     fi
 
+    # ENABLE DUAL CAN
+    if [ "${ENABLE_DUAL_CAN}" = "1" ]; then
+        echo "# Enable DUAL CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        echo "dtoverlay=mcp2515-can1,oscillator=16000000,interrupt=24" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
     # ENABLE CAN
-    if [ "${ENABLE_CAN}" = "1" ]; then
+    elif [ "${ENABLE_CAN}" = "1" ]; then
         echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
         echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
     fi