i2c-tools - Mode 'd' for i2cdump - 4 byte read support.

Current 'i2c-tools' utilities appear to be insufficient
for one particular chip the Witherspoon lab team would
like to interact with. The chip in question requires a
4 consecutive byte read without initial write of the
regiser offset. Adding an enhancement to the existing
utilities seems to be a better option than creating a
brand new tool.

Resolves openbmc/openbmc#466.

Change-Id: Ifb7f68fb8f1112eaf494634b37dafb60d200fefd
Signed-off-by: Sergey Solomin <sergey.solomin@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-devtools/i2c-tools/i2c-tools_%.bbappend b/meta-phosphor/common/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
index 599394d..c26f3f0 100644
--- a/meta-phosphor/common/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
+++ b/meta-phosphor/common/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
@@ -1,5 +1,7 @@
 # Prefer the Yocto mirror over the direct lm-sensors download.
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI_remove = "http://dl.lm-sensors.org/i2c-tools/releases/${BP}.tar.bz2"
-SRC_URI =+ "http://downloads.yoctoproject.org/mirror/sources/${BP}.tar.bz2"
+SRC_URI =+ "http://downloads.yoctoproject.org/mirror/sources/${BP}.tar.bz2 \
+            file://0001-4-byte-read-support-466.patch"
 
 RDEPENDS_${PN}_remove = "${PN}-misc"