Tell the mapper about IBM D-Bus paths

Add /com/ibm and com.ibm to the lists that the mapper
uses to know what paths and interfaces to handle.

As this is in the meta-ibm layer, it is only applied to
IBM systems.

Change-Id: I8c3624f4bff86af178b4d951632019d81dcaaf51
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
new file mode 100644
index 0000000..8347b9e
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
@@ -0,0 +1,10 @@
+SUMMARY="Add /com/ibm namespace to phosphor-mapper"
+DESCRIPTION="Add the /com/ibm path namespace and \
+com.ibm interface prefix to the mapper watch list."
+
+inherit phosphor-mapper
+inherit native
+inherit obmc-phosphor-license
+
+PHOSPHOR_MAPPER_NAMESPACE_append = " /com/ibm"
+PHOSPHOR_MAPPER_INTERFACE_append = " com.ibm"