meta-facebook: yosemite4: fix power sequence operations

There were a few issues in the phosphor-state-manager relationships
that prevented the Host and Chassis dbus objects from reflecting
reality.  Adjust them accordingly.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I3bac67d447d0e99fbe1b0f32ee04c1e5a12b8d98
diff --git a/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 70672d3..86e1249 100644
--- a/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -11,6 +11,17 @@
     obmc-host-reboot@{}.target.requires/phosphor-reboot-host@{}.service \
     "
 
+# In order to start the host, we need to ensure the chassis is on also.
+HOST_DEFAULT_TARGETS:append:yosemite4 = " \
+    obmc-host-start@{}.target.requires/obmc-chassis-poweron@{}.target \
+    "
+
+# When we issue a shutdown we need to "stop" the host also so that the
+# Host.CurrentHostState goes to "Off".
+HOST_DEFAULT_TARGETS:append:yosemite4 = " \
+    obmc-host-shutdown@{}.target.requires/obmc-host-stop@{}.target \
+    "
+
 CHASSIS_DEFAULT_TARGETS:remove:yosemite4 = " \
     obmc-chassis-powerreset@{}.target.requires/phosphor-reset-chassis-on@{}.service \
     obmc-chassis-powerreset@{}.target.requires/phosphor-reset-chassis-running@{}.service \
@@ -18,6 +29,13 @@
     obmc-chassis-poweron@{}.target.requires/obmc-power-start@{}.service \
     "
 
+# When we power off the host, we do not want to do a full chassis power-off
+# because that will turn off power to the compute card standby domain (and
+# we lose communication with the BIC.
+CHASSIS_DEFAULT_TARGETS:remove:yosemite4 = " \
+    obmc-host-shutdown@{}.target.requires/obmc-chassis-poweroff@{}.target \
+    "
+
 SRC_URI:append:yosemite4 = " \
     file://chassis-poweroff@.service \
     file://chassis-poweron@.service \