meta-openembedded: subtree update:01d539b324..fd1a0c9210

Adrian Bunk (1):
      xmlrpc-c: Remove the RDEPENDS on perl

Denys Dmytriyenko (1):
      mariadb: update SRC_URI to use archive.mariadb.org

Khem Raj (7):
      xorg-fonts-100dpi: Change License Custom -> MIT
      fio: Depend on coreutils-native for fmt utility
      fio: Fix build when march is armv7ve
      pmdk: Update to 1.7
      README: Document need for 32bit compiler
      mongodb: Turn system libpcre support into packageconfig
      grpc: Update to 1.24.1

Otavio Salvador (1):
      modemmanager: Upgrade 1.10.2 -> 1.10.6

Palmer Dabbelt (1):
      Add zeus compatibility to all layer.conf files

Peiran Hong (1):
      tcpdump: upgrade 4.9.2 -> 4.9.3

Stefan Agner (1):
      zram: properly implement systemd service

Stefan Wiehler (1):
      nvme-cli: upgrade 1.6 -> 1.9

Trevor Gamblin (2):
      gnome-desktop3: upgrade from 3.32.0 to 3.34.0
      freeradius: add -latomic for armv5

William A. Kennington III via Openembedded-devel (1):
      log4cpp: Stop using RC as a variable

Change-Id: I9b3bd69a061da11a59d38bce42543cb090b24601
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb b/meta-openembedded/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
new file mode 100644
index 0000000..256d83f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
@@ -0,0 +1,29 @@
+SUMMARY = "NVMe management command line interface"
+AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
+HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
+DEPENDS = "util-linux util-linux-native"
+PV .= "+git${SRCPV}"
+
+SRC_URI = "git://github.com/linux-nvme/nvme-cli.git"
+SRCREV = "977e7d4cf59c3c7f89e9c093c91f991b07292e45"
+
+S = "${WORKDIR}/git"
+
+inherit bash-completion systemd
+
+do_install() {
+    oe_runmake install DESTDIR=${D} PREFIX=${prefix} \
+        UDEVDIR=${nonarch_base_libdir}/udev SYSTEMDDIR=${systemd_unitdir}
+}
+
+pkg_postinst_ontarget_${PN}() {
+    ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
+}
+
+PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
+
+FILES_${PN}-dracut = "${libdir}/dracut/dracut.conf.d"
+FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"