sched-host-tran: enable in ibm images

The plan on IBM systems is that the host software will communicate via
PLDM which will utilize the D-Bus properties provided by this function.

Note that the new D-Bus interfaces provided by this function could also
be supported via Redfish. The PowerOnDelaySeconds and
PowerOffDelaySeconds properties within the ComputerSystem object would
map to what's provided here. There are no plans currently to do this
though as IBM's only use case is controlling this function via the
in-band PLDM interface.

Tested:
- Verified the generated image had scheduling service and function
  worked as expected scheduling a power on then power off

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I781dfba0871853feafed49faa72bf1c05f657d85
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index a982e12..075cdda 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -1 +1,6 @@
 EXTRA_OEMESON_witherspoon += "-Dwarm-reboot=disabled"
+
+# The scheduled-host-transition package provides support to
+# schedule power on and off operations for the host at some
+# time in the future. IBM systems will utilize this feature
+RRECOMMENDS_${PN}-host += "${PN}-scheduled-host-transition"