meta-phosphor: health: Add health monitor recipe

Added new recipe for health monitor application which collects and
monitor health sensor statistics

(From meta-phosphor rev: 4d2032e9e190e02e8608939eeebdea785ea53772)

Change-Id: Iae501b862990b1dc51460e360d67cfd36d00d3fe
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
new file mode 100644
index 0000000..40ff058
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "BMC Health Monitoring"
+DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
+HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "nlohmann-json"
+
+SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=git"
+SRCREV = "e279530e9232a8a5f61d8124628a16a901c5cef1"
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "phosphor-health-monitor.service"