meta-openembedded: subtree update:509d40153d..1e8bc46e55

Adrian Bunk (5):
      networkmanager: musl now supports secure_getenv
      libuser: musl now supports secure_getenv
      libgit2: Upgrade 0.27.8 -> 0.27.9
      poppler: Stop using USE_FIXEDPOINT
      networkmanager: Upgrade 1.18.0 -> 1.18.2

Andreas Müller (10):
      xfce4-time-out-plugin: upgrade 1.0.2 -> 1.0.3
      xfce4-battery-plugin: 1.1.2 -> 1.1.3
      xfce4-smartbookmark-plugin: upgrade 0.5.0 -> 0.5.1
      xfce4-wavelan-plugin: upgrade 0.6.0 -> 0.6.1
      xfce4-netload-plugin: upgrade 1.3.1 -> 1.3.2
      xfce4-systemload-plugin: upgrade 1.2.2 -> 1.2.3
      xfce4-mpc-plugin: upgrade 0.5.1 -> 0.5.2
      xfce4-fsguard-plugin: upgrade 1.1.0 -> 1.1.1
      xfce4-diskperf-plugin: upgrade 2.6.1 -> 2.6.2
      gigolo: upgrade 0.4.2 -> 0.5.0

Anuj Mittal (2):
      clinfo: add recipe
      ade: add recipe

Hongxu Jia (1):
      lvm2: fix circular dependencies while systemd enable cryptsetup

Jan Kaisrlik (1):
      networkd-dispatcher: service file is using different location of binary

Johannes Pointner (1):
      libtinyxml2: update to 7.1.0

Martin Jansa (1):
      python-socketio: prevent python2 socketio depending on python3-aiohttp

Piotr Tworek (3):
      libgee: Update to version 0.20.2
      gnome-bluetooth: Update to version 3.32.1.
      gnome-keyring: Update to version 3.28.2

Yi Zhao (1):
      apache2: upgrade 2.4.39 -> 2.4.41

Yuan Chao (5):
      libnftnl: upgrade 1.1.3 -> 1.1.4
      libtdb: upgrade 1.4.0 -> 1.4.1
      python-flask-pymongo: upgrade 0.5.1 -> 2.3.0
      xfsprogs: upgrade 5.2.0 -> 5.2.1
      python-protobuf: upgrade 3.9.0 -> 3.9.1

Zang Ruochen (1):
      cryptsetup: upgrade 2.1.0 -> 2.2.0.

Change-Id: I4db480893fc3b39cc7e014dbca0adc9c5317abf1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb b/meta-openembedded/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb
new file mode 100644
index 0000000..8dc11c8
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Password and keyring managing daemon"
+HOMEPAGE = "http://www.gnome.org/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+SECTION = "x11/gnome"
+
+LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = " \
+    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit distro_features_check gnomebase remove-libtool gettext upstream-version-is-even
+
+DEPENDS = " \
+    intltool-native \
+    glib-2.0-native \
+    gtk+3 \
+    gcr \
+    libgcrypt \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \
+"
+
+SRC_URI[archive.md5sum] = "284580f954f762caf62aed2ae7358177"
+SRC_URI[archive.sha256sum] = "81171b7d07211b216b4c9bb79bf2deb3deca18fe8d56d46dda1c4549b4a2646a"
+SRC_URI += "file://musl.patch"
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
+
+EXTRA_OECONF = "--disable-doc \
+                ac_cv_path_SSH_AGENT=${bindir}/ssh-agent \
+                ac_cv_path_SSH_ADD=${bindir}/ssh-add"
+
+PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
+PACKAGECONFIG[pam] = "--enable-pam --with-pam-dir=${base_libdir}/security, --disable-pam"
+PACKAGECONFIG[ssh-agent] = "--enable-ssh-agent,--disable-ssh-agent,,openssh-misc"
+
+FILES_${PN} += " \
+    ${datadir}/dbus-1/services \
+    ${datadir}/p11-kit \
+    ${base_libdir}/security/*${SOLIBSDEV} \
+    ${libdir}/pkcs11/gnome-keyring-pkcs11.so \
+"