meta-openembedded: subtree update:509d40153d..1e8bc46e55

Adrian Bunk (5):
      networkmanager: musl now supports secure_getenv
      libuser: musl now supports secure_getenv
      libgit2: Upgrade 0.27.8 -> 0.27.9
      poppler: Stop using USE_FIXEDPOINT
      networkmanager: Upgrade 1.18.0 -> 1.18.2

Andreas Müller (10):
      xfce4-time-out-plugin: upgrade 1.0.2 -> 1.0.3
      xfce4-battery-plugin: 1.1.2 -> 1.1.3
      xfce4-smartbookmark-plugin: upgrade 0.5.0 -> 0.5.1
      xfce4-wavelan-plugin: upgrade 0.6.0 -> 0.6.1
      xfce4-netload-plugin: upgrade 1.3.1 -> 1.3.2
      xfce4-systemload-plugin: upgrade 1.2.2 -> 1.2.3
      xfce4-mpc-plugin: upgrade 0.5.1 -> 0.5.2
      xfce4-fsguard-plugin: upgrade 1.1.0 -> 1.1.1
      xfce4-diskperf-plugin: upgrade 2.6.1 -> 2.6.2
      gigolo: upgrade 0.4.2 -> 0.5.0

Anuj Mittal (2):
      clinfo: add recipe
      ade: add recipe

Hongxu Jia (1):
      lvm2: fix circular dependencies while systemd enable cryptsetup

Jan Kaisrlik (1):
      networkd-dispatcher: service file is using different location of binary

Johannes Pointner (1):
      libtinyxml2: update to 7.1.0

Martin Jansa (1):
      python-socketio: prevent python2 socketio depending on python3-aiohttp

Piotr Tworek (3):
      libgee: Update to version 0.20.2
      gnome-bluetooth: Update to version 3.32.1.
      gnome-keyring: Update to version 3.28.2

Yi Zhao (1):
      apache2: upgrade 2.4.39 -> 2.4.41

Yuan Chao (5):
      libnftnl: upgrade 1.1.3 -> 1.1.4
      libtdb: upgrade 1.4.0 -> 1.4.1
      python-flask-pymongo: upgrade 0.5.1 -> 2.3.0
      xfsprogs: upgrade 5.2.0 -> 5.2.1
      python-protobuf: upgrade 3.9.0 -> 3.9.1

Zang Ruochen (1):
      cryptsetup: upgrade 2.1.0 -> 2.2.0.

Change-Id: I4db480893fc3b39cc7e014dbca0adc9c5317abf1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-support/libtdb/libtdb_1.4.1.bb b/meta-openembedded/meta-networking/recipes-support/libtdb/libtdb_1.4.1.bb
new file mode 100644
index 0000000..d25c3fa
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-support/libtdb/libtdb_1.4.1.bb
@@ -0,0 +1,57 @@
+SUMMARY = "The tdb library"
+HOMEPAGE = "http://tdb.samba.org/"
+SECTION = "libs"
+LICENSE = "LGPL-3.0+ & GPL-3.0+"
+
+LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
+                    file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
+
+SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
+           file://tdb-Add-configure-options-for-packages.patch \
+           file://0001-waf-add-support-of-cross_compile.patch \
+"
+
+SRC_URI[md5sum] = "d1d0a5d43614add17d1e41bbdb209446"
+SRC_URI[sha256sum] = "dd4ecd9678e8d3ea772623bd81fe49b43363a2f970a76fb5468322753787aa4b"
+
+PACKAGECONFIG ??= "\
+    ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
+"
+
+PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
+PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
+PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
+PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
+PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
+PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
+
+S = "${WORKDIR}/tdb-${PV}"
+
+inherit waf-samba
+
+#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
+#to cross Popen
+export WAF_NO_PREFORK="yes"
+
+EXTRA_OECONF += "--disable-rpath \
+                 --bundled-libraries=NONE \
+                 --builtin-libraries=replace \
+                 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
+                "
+
+do_install_append() {
+     # add this link for cross check python module existence. eg: on x86-64 host, check python module
+     # under recipe-sysroot which is mips64.
+     cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s tdb.*.so tdb.so
+}
+
+PACKAGES += "tdb-tools python3-tdb"
+
+RPROVIDES_${PN}-dbg += "python3-tdb-dbg"
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_tdb-tools = "${bindir}/*"
+FILES_python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
+RDEPENDS_python3-tdb = "python3"
+INSANE_SKIP_${MLPREFIX}python3-tdb = "dev-so"