meta-google: nanopb: Update from 0.4.5 -> 0.4.8

This is intended to fix some build issues with the old 0.4.5 package and
splits the generator bits out from the runtime bits. The change was
taken from meta-openembedded@341c47848d04a2114b8c794ef6e01b03c80c801a
and these files will eventually be deleted.

Change-Id: If9e5886ff584305da9057a9de79e15fe288843fb
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/nanopb/nanopb.bb b/meta-google/recipes-google/nanopb/nanopb.bb
new file mode 100644
index 0000000..7ad6a32
--- /dev/null
+++ b/meta-google/recipes-google/nanopb/nanopb.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Combined nanopb package"
+PV = "1.0"
+PR = "r1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+DEPENDS = " \
+    nanopb-generator \
+    nanopb-runtime \
+"
+
+RDEPENDS:${PN} = " \
+    nanopb-generator \
+    nanopb-runtime \
+"