meta-openembedded: subtree update:1bfaa2e63a..64224b92e5

Adrian Bunk (1):
      networkmanager: Upgrade 1.18.2 -> 1.18.4

Alistair Francis (5):
      mycroft: Bump to 19.8.1
      mycroft: Run the files from /var
      python3-monotonic: Initial commit of version 1.5
      python3-msk: Initial commit of version 0.3.13
      python3-google-api-python-client: Initial commit of 1.7.11

Andreas Müller (3):
      exiv2: initial add 0.27.1
      menulibre: upgrade 2.2.0 -> 2.2.1
      libmbim: upgrade 1.18.0 -> 1.20.0

Callaghan, Dan (1):
      strongswan: add a PACKAGECONFIG for libbfd stack traces

Changqing Li (1):
      kea: fix kea-dhcp4.service/kea-dhcp6.service start up failed

Christophe PRIOUZEAU (14):
      xfce4-mpc-plugin: Clarify BSD license variant
      xfce4-diskperf-plugin: Clarify BSD license variant
      xfce4-wavelan-plugin: Clarify BSD license variant
      libmpdclient: Clarify BSD license variant
      tremor: Clarify BSD license variant
      xscreensaver: Clarify BSD license variant
      openjpeg: Clarify BSD license variant
      sdparm: Clarify BSD license variant
      onig: Clarify BSD license variant
      libssh2: Clarify BSD license variant
      libsmi: Clarify BSD license variant
      libinih: Clarify BSD license variant
      gperftools: Clarify BSD license variant
      daemonize: Clarify BSD license variant

Fabio Berton (1):
      ifplugd: Add recipe for version 0.28

George Kiagiadakis (1):
      pipewire: Initial add of 0.2.7

Hongxu Jia (1):
      lvm2/libdevmapper: 2.03.02 -> 2.03.05

Khem Raj (4):
      wvstreams,wvdial: Mark incompatible for musl
      pidgin-sipe: Upgrade to 1.25.0
      dconf: Upgrade to 0.34.0
      libsmi: Fix and operator per SPDX

Martin Siegumfeldt (3):
      Revert "libiio: fix build of python bindins"
      libiio: allow python3 bindings to be built
      libiio: bump to version 0.18+

Stefan Wiehler (1):
      nvme-cli: defer host ID generation to post installation

Tekkub (1):
      nlohmann-fifo: Add recipe

Trevor Gamblin (2):
      rsyslog: fix CVE-2019-17041
      quagga: fix PIDFile path for service files

Yi Zhao (2):
      freeradius: fix CVE-2019-10143
      ipvsadm: install initscript to /etc/init.d

Zang Ruochen (9):
      python-paste: upgrade 3.2.1 -> 3.2.2
      python-pip: upgrade 19.2.3 -> 19.3
      python-pyasn1-modules: upgrade 0.2.6 -> 0.2.7
      python-pytest: upgrade 5.1.3 -> 5.2.1
      python-pytz: upgrade 2019.2 -> 2019.3
      python-xxhash: upgrade 1.4.1 -> 1.4.2
      python-cffi: upgrade 1.12.3 -> 1.13.0
      python-jsonschema: upgrade 3.0.2 -> 3.1.1
      protobuf: upgrade 3.9.2 -> 3.10.0

Change-Id: I72806dd6bfe6427787917f687d058c6ced02a00c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
new file mode 100644
index 0000000..d4ac409
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
@@ -0,0 +1,85 @@
+SUMMARY = "Mycroft is a hackable open source voice assistant."
+DESCRIPTION = "Mycroft is the world’s first open source assistant. "
+HOMEPAGE = "https://mycroft.ai/"
+SECTION = "multimedia"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=79aa497b11564d1d419ee889e7b498f6"
+
+SRCREV = "913f29d3d550637934f9abf43a097eb2c30d76fc"
+SRC_URI = "git://github.com/MycroftAI/mycroft-core.git;branch=master \
+           file://0001-Remove-python-venv.patch \
+           file://0002-dev_setup.sh-Remove-the-git-dependency.patch \
+           file://0003-dev_setup.sh-Remove-the-TERM-dependency.patch \
+           file://0004-pip-requirements-Don-t-install-requirements-with-pip.patch \
+           file://0005-Use-python3-and-pip3-instead-of-python-and-pip.patch \
+           file://dev_opts.json \
+           file://mycroft-setup.service \
+           file://mycroft.service \
+          "
+
+S = "${WORKDIR}/git"
+
+inherit systemd
+
+# Mycroft installs itself on the host
+# Just copy the setup files to the rootfs
+# The mycroft-setup service will copy the files to /var/ where we run them from
+do_install() {
+    install -d ${D}${libdir}/
+    cp -r ${B} ${D}${libdir}/mycroft
+    rm -r ${D}${libdir}/mycroft/.git
+
+    # Install the dev opts so it doesn't ask us on initial setup.
+    install -m 644 ${WORKDIR}/dev_opts.json ${D}${libdir}/mycroft/.dev_opts.json
+
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -d ${D}${systemd_unitdir}/system
+        install -m 644 ${WORKDIR}/mycroft-setup.service ${D}${systemd_unitdir}/system
+        sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft-setup.service
+    fi
+
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -d ${D}${systemd_unitdir}/system
+        install -m 644 ${WORKDIR}/mycroft.service ${D}${systemd_unitdir}/system
+        sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft.service
+    fi
+}
+
+FILES_${PN} += "${libdir}/mycroft"
+
+RDEPENDS_${PN} = "python3"
+
+RDEPENDS_${PN} += "python3-requests python3-pillow \
+                   python3-tornado python3-pyyaml \
+                   python3-pyalsaaudio python3-inflection \
+                   python3-pyserial python3-psutil \
+                   python3-pyaudio python3-fann2 \
+                   python3-pocketsphinx \
+                   python3-xxhash python3-pako \
+                   python3-six python3-cryptography \
+                   python3-requests-futures \
+                   python3-xmlrunner python3-fasteners \
+                   python3-python-vlc \
+                   python3-padatious python3-padaos \
+                   python3-petact python3-precise-runner \
+                   python3-pulsectl python3-pychromecast \
+                   python3-msm python3-msk \
+                   python3-websocket-client \
+                   python3-google-api-python-client \
+                 "
+
+# These packages need to be installed on the target
+# python3-speechrecognition python3-pyee==5.0.0 python3-six==1.10.0
+# python3-websocket-client==0.54.0 python3-gtts python3-gtts-token
+# python3-python-dateutil python3-adapt-parser python3-lazy
+
+# Mycroft uses Alsa, PulseAudio and Flac
+RDEPENDS_${PN} += "alsa-utils alsa-plugins alsa-tools"
+RDEPENDS_${PN} += "pulseaudio pulseaudio-misc pulseaudio-server"
+RDEPENDS_${PN} += "flac"
+
+# Mycroft can do this itself on the target, but it's quicker to do it here
+RDEPENDS_${PN} += "mimic"
+
+SYSTEMD_SERVICE_${PN} = "mycroft-setup.service mycroft.service"