meta-openembedded: subtree update:1bfaa2e63a..64224b92e5

Adrian Bunk (1):
      networkmanager: Upgrade 1.18.2 -> 1.18.4

Alistair Francis (5):
      mycroft: Bump to 19.8.1
      mycroft: Run the files from /var
      python3-monotonic: Initial commit of version 1.5
      python3-msk: Initial commit of version 0.3.13
      python3-google-api-python-client: Initial commit of 1.7.11

Andreas Müller (3):
      exiv2: initial add 0.27.1
      menulibre: upgrade 2.2.0 -> 2.2.1
      libmbim: upgrade 1.18.0 -> 1.20.0

Callaghan, Dan (1):
      strongswan: add a PACKAGECONFIG for libbfd stack traces

Changqing Li (1):
      kea: fix kea-dhcp4.service/kea-dhcp6.service start up failed

Christophe PRIOUZEAU (14):
      xfce4-mpc-plugin: Clarify BSD license variant
      xfce4-diskperf-plugin: Clarify BSD license variant
      xfce4-wavelan-plugin: Clarify BSD license variant
      libmpdclient: Clarify BSD license variant
      tremor: Clarify BSD license variant
      xscreensaver: Clarify BSD license variant
      openjpeg: Clarify BSD license variant
      sdparm: Clarify BSD license variant
      onig: Clarify BSD license variant
      libssh2: Clarify BSD license variant
      libsmi: Clarify BSD license variant
      libinih: Clarify BSD license variant
      gperftools: Clarify BSD license variant
      daemonize: Clarify BSD license variant

Fabio Berton (1):
      ifplugd: Add recipe for version 0.28

George Kiagiadakis (1):
      pipewire: Initial add of 0.2.7

Hongxu Jia (1):
      lvm2/libdevmapper: 2.03.02 -> 2.03.05

Khem Raj (4):
      wvstreams,wvdial: Mark incompatible for musl
      pidgin-sipe: Upgrade to 1.25.0
      dconf: Upgrade to 0.34.0
      libsmi: Fix and operator per SPDX

Martin Siegumfeldt (3):
      Revert "libiio: fix build of python bindins"
      libiio: allow python3 bindings to be built
      libiio: bump to version 0.18+

Stefan Wiehler (1):
      nvme-cli: defer host ID generation to post installation

Tekkub (1):
      nlohmann-fifo: Add recipe

Trevor Gamblin (2):
      rsyslog: fix CVE-2019-17041
      quagga: fix PIDFile path for service files

Yi Zhao (2):
      freeradius: fix CVE-2019-10143
      ipvsadm: install initscript to /etc/init.d

Zang Ruochen (9):
      python-paste: upgrade 3.2.1 -> 3.2.2
      python-pip: upgrade 19.2.3 -> 19.3
      python-pyasn1-modules: upgrade 0.2.6 -> 0.2.7
      python-pytest: upgrade 5.1.3 -> 5.2.1
      python-pytz: upgrade 2019.2 -> 2019.3
      python-xxhash: upgrade 1.4.1 -> 1.4.2
      python-cffi: upgrade 1.12.3 -> 1.13.0
      python-jsonschema: upgrade 3.0.2 -> 3.1.1
      protobuf: upgrade 3.9.2 -> 3.10.0

Change-Id: I72806dd6bfe6427787917f687d058c6ced02a00c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
index cc0efcc..4e57d5b 100644
--- a/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -4,14 +4,15 @@
 LICENSE = "LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
 
-SRCREV = "6ecff5d46e1b12c2859f0b63a73282940e3402bb"
-PV = "0.15+git${SRCPV}"
+# v0.18 + a single commit fixing the build
+SRCREV = "5090603d01779bb1717fb0c50953330e8770550f"
+PV = "0.18+git${SRCPV}"
 
 SRC_URI = "git://github.com/analogdevicesinc/libiio.git;protocol=https"
 
 S = "${WORKDIR}/git"
 
-inherit cmake pythonnative systemd
+inherit cmake python3native systemd
 
 DEPENDS = " \
     flex-native bison-native libaio \
@@ -24,22 +25,21 @@
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DWITH_SYSTEMD=ON -DSYSTEMD_UNIT_INSTALL_DIR=${systemd_system_unitdir}', '', d)} \
 "
 
-PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND PYTHON_BINDINGS"
+PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND"
 
 PACKAGECONFIG[USB_BACKEND] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1,libxml2"
 PACKAGECONFIG[NETWORK_BACKEND] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2"
-PACKAGECONFIG[PYTHON_BINDINGS] = ",,python"
 
-PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-python"
+PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-${PYTHON_PN}"
 
-RDEPENDS_${PN}-python = "${PN} python-ctypes python-stringold"
+RDEPENDS_${PN}-${PYTHON_PN} = "${PN} ${PYTHON_PN}-ctypes ${PYTHON_PN}-stringold"
 
 FILES_${PN}-iiod = " \
     ${sbindir}/iiod \
     ${systemd_system_unitdir}/iiod.service \
 "
 FILES_${PN}-tests = "${bindir}"
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
+FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
 
 SYSTEMD_PACKAGES = "${PN}-iiod"
 SYSTEMD_SERVICE_${PN}-iiod = "iiod.service"