meta-phosphor: ipmitool: patch for fru edit fixes

This commit is a temporary patch which is a copy of:
https://codeberg.org/IPMITool/ipmitool/pulls/1

The current implementation of ipmitool fru edit does not perform proper
checks when attempting to resize the FRU. This results in undesireable
changes to the FRU in several instances.

This commit resolves these issues to ensure proper handling when
decreasing or increasing the FRU size.

Tested:
Built OpenBMC with only this patch for ipmitool and performed the tests
described in the patched commit with the same results.

Change-Id: I0305277740c55f4a314111acfc556758f14828d4
Signed-off-by: Alex Schendel <alex.schendel@intel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index f4a258f..28a1524 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -5,6 +5,12 @@
 PV = "1.8.18+git${SRCPV}"
 
 SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
+
+# Temporary patch for https://codeberg.org/IPMITool/ipmitool/pulls/1
+SRC_URI += " \
+    file://0001-Fru-Fix-edit-field-not-checking-area-existence.patch \
+"
+
 # TODO: when a new company joins the OpenBMC project by signing
 #       a CLA, if they have an enterprise number on file with the
 #       IANA, the versioned file, $PWD/ipmitool/enterprise-numbers