sdbusplus: Avoid race conditions in native context

Help sdbusplus-native clients out by ensuring runtime
dependencies are installed.

Change-Id: I7b675a5eec0e9f4bda7f4bd1fcf3de9d97c0e3a7
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
index ac51384..dd2ca6c 100644
--- a/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
+++ b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
@@ -15,6 +15,21 @@
         python-pyyaml \
         "
 
+# sdbus++ has a handful of runtime dependencies on other python packages.
+# Bitbake doesn't do anything with RDEPENDS in native context because
+# native context doesn't have packages.
+#
+# While technically sdbus++ doesn't require its runtime dependencies to be
+# installed to build, work around the above native context behavior
+# by adding a build dependency so that clients don't have to DEPEND
+# on sdbus++ runtime dependencies manually.
+
+DEPENDS_append_class-native = " \
+        python-inflection-native \
+        python-mako-native \
+        python-pyyaml-native \
+        "
+
 SRC_URI += "git://github.com/openbmc/sdbusplus"
 SRCREV = "b6dcf97fdf0d9c673812942f5b4e8b2691ceb5a3"