Make host-check a part of host state function

In the previous review it was noted that it didn't make much sense
for host-check to be it's own provided function in OpenBMC. It's more
of a recommended piece of the base host state function.

Change-Id: I024472e96ea00f411e8348e0221c210f84700019
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
index 672090e..67988f5 100644
--- a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
@@ -25,10 +25,14 @@
 SYSTEMD_PACKAGES = "${PN}-discover \
                     ${PN}-reset-sensor-states \
 "
+
+# The host-check function will check if the host is running
+# after a BMC reset.
 # The reset-sensor-states function will reset the host
-# sensors on a BMC reset or system power loss so it is
-# recommended when bringing in the host state function
-RRECOMMENDS_${PN}-host = "${PN}-reset-sensor-states"
+# sensors on a BMC reset or system power loss.
+# Neither is required for host state function but are
+# recommended to deal properly with these reset scenarios.
+RRECOMMENDS_${PN}-host = "${PN}-host-check ${PN}-reset-sensor-states"
 
 inherit autotools pkgconfig
 inherit obmc-phosphor-dbus-service