phosphor-reboot-host: Use environment file for sleep

By default phosphor-reboot-host@.service sleeps for 5 seconds between
power off and power on.
Make the sleep time as configurable parameter in environment, so
different machines could use different sleep time.

Tested: Verify the sleep time is from the config file.

Change-Id: I81d17e56010fe595dd46295923746f8678678209
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
index 4c642dd..0b974c2 100644
--- a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
@@ -52,6 +52,7 @@
 FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager"
 DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
 DBUS_SERVICE_${PN}-host += "phosphor-reboot-host@.service"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-host += "obmc/phosphor-reboot-host/reboot.conf"
 SYSTEMD_SERVICE_${PN}-host += "phosphor-reset-host-reboot-attempts@.service"
 
 FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager"