meta-phosphor: add new recipe for phosphor-ipmi-flash

Add recipe for phosphor-ipmi-flash.  This package provides an
implementation of in-band firmware update that leverages the BLOB
protocol (phosphor-ipmi-blobs).

(From meta-phosphor rev: 2ff2eccafde5cb4d53547eb1481f29ea4a834e18)

Change-Id: I2ee7b6ecc18a98f451d053a879f5eca9e4ef5598
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
new file mode 100644
index 0000000..b0767b5
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -0,0 +1,25 @@
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
+SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
+DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-blobs"
+DEPENDS += "phosphor-logging"
+DEPENDS += "sdbusplus"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
+SRCREV = "4306f68bf44ee0487422bf75adb6bc2f8c1ea26c"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"