phosphor-mapper: remove deprecated path whitelist
The c++ mapper implements dbus service whitelists in place of path
based whitelists. Drop support for path whitelists.
(From meta-phosphor rev: d4816d2868a251a0a4048219de0e9411eed8c853)
Change-Id: I7ca6c4b01e644b8008169cc63c9259801c42f27f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/phosphor-mapper.bbclass b/meta-phosphor/classes/phosphor-mapper.bbclass
index 97da850..3374a76 100644
--- a/meta-phosphor/classes/phosphor-mapper.bbclass
+++ b/meta-phosphor/classes/phosphor-mapper.bbclass
@@ -7,14 +7,11 @@
# interfaces it will keep track of.
#
# The Phosphor layer by default configures the mapper to
-# watch xyz.openbmc_project services, interfaces and paths
-# only. This configuration file is intended to be inherited
-# by native recipes in other layers that wish to add namespaces
+# watch xyz.openbmc_project services and interfaces only.
+# This configuration file is intended to be inherited by
+# native recipes in other layers that wish to add namespaces
# or interfaces to the mapper watchlist.
-# Add path namespaces to be monitored:
-# PHOSPHOR_MAPPER_NAMESPACE_append = " /foo/bar"
-
# Add service namespaces to be monitored:
# PHOSPHOR_MAPPER_SERVICE_append = " foo.bar"
@@ -39,13 +36,11 @@
with open(path, 'w+') as fd:
pass
- process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE', 'namespace_dir')
process_var(d, 'PHOSPHOR_MAPPER_SERVICE', 'service_dir')
process_var(d, 'PHOSPHOR_MAPPER_INTERFACE', 'interface_dir')
process_var(d, 'PHOSPHOR_MAPPER_SERVICE_BLACKLIST', 'serviceblacklist_dir')
}
-do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE"
do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE"
do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE"
do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE_BLACKLIST"