Install GPIO definition JSON

The code in libopenbmc_intf.so looks for the GPIO definition file
/etc/default/obmc/gpio/gpios_defs.json.  Install it from this
recipe.

The actual JSON files should go into the corresponding directories
in the machine layers along with a bbappend of this recipe to
set FILESEXTRAPATHS_prepend.

(From meta-phosphor rev: 728258c6a235f75176ea213e671d7a93904ca72a)

Change-Id: I3969e005cbdfd04ae8cec1c13c3c3bb625dca574
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
index 09027dd..b02b832 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
@@ -7,9 +7,15 @@
 inherit pkgconfig
 
 DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
 
 SKELETON_DIR = "libopenbmc_intf"
 
+SRC_URI += "file://gpio_defs.json"
+
 do_install() {
         oe_runmake install DESTDIR=${D}
+
+        install -d ${D}${sysconfdir}/default/obmc/gpio/
+        install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
 }