Change obmc-phosphor-fan to use fanctl

A new fanctl module is added in skeleton to replace pyfanctl.
fanctl is written in C instead of python.

Partially resolves openbmc/openbmc#93

Change-Id: I404176f3d526027abac089a4c168240ba6ae69b1
Signed-off-by: Yi Li <adamliyi@msn.com>
diff --git a/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
index 256f9fc..501f54a 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
@@ -2,14 +2,11 @@
 DESCRIPTION = "OpenBMC fan control."
 PR = "r1"
 
-inherit skeleton-python
+inherit skeleton-sdbus
 inherit obmc-phosphor-dbus-service
 
-RDEPENDS_${PN} += "\
-        python-dbus \
-        python-pygobject \
-        pyphosphor-dbus \
-        "
-SKELETON_DIR = "pyfanctl"
+RDEPENDS_${PN} += "libsystemd"
+SKELETON_DIR = "fanctl"
+
 DBUS_SERVICE_${PN} += "org.openbmc.control.Fans.service"
 SYSTEMD_SERVICE_${PN} += "obmc-max-fans.service"