meta-hpe:  add new meta layer for rl300-g11

Signed-off-by: Charles Kearney <charles.kearney@hpe.com>
Change-Id: I650f926349ef2a57c352aac36a801b07fb4001ca
diff --git a/meta-hpe/meta-gxp/classes/gxp2-bootblock-n.bbclass b/meta-hpe/meta-gxp/classes/gxp2-bootblock-n.bbclass
new file mode 100644
index 0000000..3ee93ff
--- /dev/null
+++ b/meta-hpe/meta-gxp/classes/gxp2-bootblock-n.bbclass
@@ -0,0 +1,21 @@
+# TODO:  Manually copy the U-Boot signing key and customer-key-block here:
+HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
+
+inherit deploy
+
+do_deploy () {
+  install -d ${DEPLOYDIR}
+
+  # Copy in the bootblock
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp2-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
+
+  # Copy in files from the files subdirectory
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header-512.sig ${DEPLOYDIR}/hpe-uboot-header-512.section
+
+  # Copy in the U-Boot signing key
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer_private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
+
+  # Copy in the customer keyblock
+  install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
+}