pldm: Add oem-ibm build option

Currently, several machines use the oem-ibm function in the
pldm_%.bbappend file. It should be added to PACKAGECONFIG in the
pldm_git recipe and disabled by default.

Signed-off-by: George Liu <liuxiwei@ieisystem.com>
Change-Id: Ia120de9ad80f24333575e3b278ff14c3272a4733
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 0531b03..0900842 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -26,12 +26,12 @@
 
 PACKAGECONFIG[transport-mctp-demux] = "-Dtransport-implementation=mctp-demux"
 PACKAGECONFIG[transport-af-mctp] = "-Dtransport-implementation=af-mctp"
+PACKAGECONFIG[oem-ibm] = "-Doem-ibm=enabled, -Doem-ibm=disabled, , squashfs-tools"
 PACKAGECONFIG ??= ""
 PACKAGECONFIG:append:df-mctp = " transport-af-mctp"
 
 EXTRA_OEMESON = " \
         -Dtests=disabled \
-        -Doem-ibm=disabled \
         "
 
 pkg_prerm:${PN} () {