Create recipe to add service for power supply SYNC

This synchronizes the energy sampling clocks between the two power
supplies in the system, which should result in better accuracy of the
measured input energy that gets reported.

Resolves: openbmc/openbmc#1737

Change-Id: I6e5d6c6277422148d916d72ab88a1fff88a3a594
Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
new file mode 100644
index 0000000..b0903e7
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Witherspoon Power Supply Sync"
+DESCRIPTION = "Synchronizes the power supplies' INPUT_HISTORY data"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+
+SYNC_SERVICE = "witherspoon-power-supply-sync.service"
+TGTFMT = "obmc-chassis-poweron@0.target"
+SYNC_FMT = "../${SYNC_SERVICE}:${TGTFMT}.wants/${SYNC_SERVICE}"
+
+SYSTEMD_SERVICE_${PN} += "${SYNC_SERVICE}"
+SYSTEMD_LINK_${PN} += "${SYNC_FMT}"