host-graceful-quiesce: install new target

Per design here:
 https://gerrit.openbmc-project.xyz/c/openbmc/docs/+/52874

phosphor-state-manager: srcrev bump 106152c646..aaa8d3466b
Allen.Wang (1):
      phosphor-state-manager: Support multi-host for persist files

Andrew Geissler (1):
      host-graceful-quiesce: introduce new target

Tested:
- Built image with new target and included pldmSoftPowerOff.service in
  it so that host firmware got a chance to gracefully shut down prior to
  Quiesce.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I83cd6a20d72cf586d21baf3fe809aad28f288695
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 2548720..7301b54 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -138,6 +138,7 @@
 #             be called by reboot and start target.
 # - stop:     Services to run to shutdown the host
 # - quiesce:  Target to enter on host boot failure
+# - graceful-quiesce:  Target to enter on host boot failure (allow host graceful shutdown)
 # - shutdown: Tell host to shutdown, then stop system
 # - reset:   Services to check if host is running and update host "start" target
 # - crash:   Target to run when host crashes. it is very much similar to
@@ -150,7 +151,7 @@
 #                      notifying the host.
 # - diagnostic-mode: This will be entered when the host is collecting diagnostic
 #                    data for itself.
-HOST_ACTION_TARGETS = "start startmin stop quiesce reset shutdown crash timeout "
+HOST_ACTION_TARGETS = "start startmin stop quiesce graceful-quiesce reset shutdown crash timeout "
 HOST_ACTION_TARGETS += "reboot warm-reboot force-warm-reboot diagnostic-mode"
 
 CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
@@ -193,6 +194,6 @@
 
 
 SRC_URI += "git://github.com/openbmc/phosphor-state-manager;branch=master;protocol=https"
-SRCREV = "106152c64631979b04cdb624ae32755ea1802603"
+SRCREV = "aaa8d3466b931b9cf5a64e3a972cd23c2b5b90c6"
 
 S = "${WORKDIR}/git"